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The ClearTeam Explorer Integration with Beanbag Review Board 
 
Code reviews are essential to an effective development process. Code reviews improve code 
quality and reduce the odds of introducing new defects. Review Board  
(https://www.reviewboard.org/) is an open-source tool that streamlines the peer-review process 
for source code.         
                 
The ClearTeam Explorer integration with Beanbag Review Board provides a direct interface for 
creating or updating review requests. This integration uses the Eclipse Review Board open-source 
plugin, which provides the wrapper layer that handles Review Board Server REST API 
communication. A review request can be submitted on a Unified Change Management (UCM) 
activity or files and folders for UCM and Base ClearCase. On Linux and Windows, four view types 
are supported: Dynamic, Snapshot, Web, and Automatic. 

This Review Board integration is available in the following forms: 

• ClearTeam Explorer (Rich Client Platform): ClearTeam Explorer (CTE) Java GUI installed as 
part of ClearCase Remote Client (CCRC) or part of ClearCase Local Client (CCLC). 

• ClearTeam Explorer for Eclipse IDE: ClearTeam Explorer that can be installed from an 
Eclipse update site and integrated into an existing Eclipse installation supplied by the 
user. 

• ClearTeam Explorer Extension - ClearTeam Explorer Extension that can be integrated 
with other Desktop tools such as RAD. 

Note: The ClearCase Remote Client (CCRC) offering installs the client components necessary to 
support Automatic and Web views and includes both a GUI (CTE) and CLI (rcleartool).  

 

Prerequisite 
 
The Review Board currently supports only diff output formatting from GNU Diff. If you use the 
integration on Windows, you might have to install GNU Diff. Make sure to set the PATH 
environment variable to include the path of the GNU Diff executable file before you submit a 
review request. The GNU Diff default installation path is C:\Program Files (x86)\GnuWin32\bin. 

 

ClearTeam Explorer for Eclipse IDE V4.24 or later 
 
The ClearTeam Explorer for Eclipse IDE Beanbag Review Board integration uses Mylyn plugins of 
Eclipse. In Eclipse V4.24 and later, the Mylyn plugins are not installed by default. If you are 
installing ClearTeam Explorer Eclipse IDE from an update site on Eclipse 4.24 or later, you might 
have to install Mylyn plugins manually: 

1. Click Eclipse Help->Install New Software. 
2. Add the Mylyn updatesite URL: http://download.eclipse.org/mylyn/releases/3.21 
3. Select the Mylyn SDKs and Frameworks -> Mylyn Tasks Connector: Eclipse IDE option 

and proceed with the installation.     

https://www.reviewboard.org/
http://gnuwin32.sourceforge.net/packages/diffutils.htm
http://download.eclipse.org/mylyn/releases/3.21
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      Log in and add the Review Board repository 

1. Install ClearCase. 
2. Start ClearTeam Explorer and open the Task Repositories view: 

click Window > Show View > Other > Mylyn > Task Repositories. 
3. Use either of the following methods to add Review Board repositories. 

• Click the Add Task Repository button located on the toolbar for the view or 

 

• Right-click in the Task Repositories view and select the Add Task Repository option. 

 

                                                                                

           
 
 
 
 
 
 
 
 
 

Figure 1: Task Repositories tab 

Figure 2: Context menu for the Task Repositories tab 
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4.  Select Reviewboard, and then click Next.             

                 

5. Enter your Review Board web URL (for example https://reviewboardserver), user 
              name, and password, and click Validate Settings    

Figure 3:  Add Task Repository 

Figure 4: Review Board Validation 
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6.  After validation, click Finish to complete the authentication. 

 
     Note: You can add multiple Review Board repositories. 

      You can submit a review request on a UCM activity or files and folders (for UCM and 
      Base ClearCase). 
 

UCM activity 
 
     New review request 
 
     You can submit new review requests on a UCM activity. To raise a new review request, right-   
     click a UCM Activity and select Review Board > Create Review Request from the available  
     menu.     

 
 

                                                               

 
 
 
 
 
 
 
 
 

Figure 5: Create Review Request 
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     Select Review Board Server dialog box 
     
     This dialog lists all the added Review Board repositories by user. You can select one. Select one  
     on which you want to submit the review request and click OK. 
     

 

 

 

 

 

 

 

 

 

 

      

Figure 6: Select Review Board Server 
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     Detect Local Changes page 

     The Detect Local Changes page contains the list of elements and their change types.  

                                               

         Review Board Repository 

         This entry shows the Review Board server address as the user configured it. 

 

         UCM Activity 

         This entry displays the activity headline for which the Review Request is being raised. It is 
         displayed only if the request is being raised for a UCM activity.    
 

         Change-Set table 

         This table displays the change set of the activity. The full file and folder path and type of 
         change (that is, modify or add) are shown. Only checked-in changes are taken into 
         consideration for Review Requests.                                         

Figure 7: Detect Local Changes 
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         Include 

         Use this checkbox column to select or deselect versions to be included or excluded for the 
         Review Request. At least one version must be selected to proceed with creating the Review 
         Request.    
     
         Check None/Check All 

         These buttons are used to deselect or select all files and folders.  
         Select the files to be submitted for a review request and click Next.    
 

    Publish Review Request page 
 
     Complete the Publish Review Request page with the details required for publishing. Note that 
     the fields with an asterisk (*) are required.    
 

Figure 8: Publish Review Request 
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          Summary* 

          Enter a review summary. 

 

          Bugs Closed 

          Enter a defect or bug number, if applicable. 

 

          Branch 

          Enter the branch on which development was done for the Review Request. 

 

          Description* 

          Enter the relevant details to the Review Request for the reviewer in this multiline field. 

 

          Testing Done 

          Enter the details of the testing done before the Review Request was raised. 

 

          Reviewers* 

          Enter either the names of the reviewers or the review group that is conducting the review. 

    

               Review People 

               Enter the Review Board user name IDs of the people who are conducting the review. 

 

               Review Group 

               Enter the name of the review group that is conducting the review. Note that group 
               names are managed by Review Board itself.     
  

          After you have provided all the Review Request details, click Finish to submit the review  
          request. 
 

     Update review request 
 
     You can update review requests on a UCM activity. To update a review request, right-click a  
     UCM activity and select Review Board > Update Review Request from the menu.   
 
     Note: Include all previously submitted elements with newly updated elements to see full and  
     proper diffs. 
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Figure 9: Update Review Request 

Figure 10: Select Review Board Server 



  

10 
 

     Detect Local Changes Page 
 
     Select a review request from the menu or enter the review request ID in the text field. 

     To select a review Request from the drop-down menu: 

                                      

   

       

 

 

 

 

 

Figure 11: Detect Local Changes 
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      To enter a review request ID in the text field: 

     Note: In the update review request flow, excluding the Detect Local Changes page, all 
     windows are identical to the create review request flow.   
     
      Select review request 

      This control opens a menu on the Detect Local Changes page. The menu includes all review  
      requests that you have submitted. You must select a review request to update. Alternatively,  
      you can enter a valid review request ID in the text field and click ValidateReviewRequest.  
 

      After the review request ID is validated, click Next to navigate to the Publish Review Request 
     page, where you can complete or update the review request details.  
 

Figure 12: Detect Local Changes 
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      Refer to Figure 8 to see the Publish Review Request page. 

      After the fields are modified on the Publish Review Request page, click Finish to update or 
      submit the review request.  
 

File and folder 
 
      New review request 

      You can submit new review requests for files and folders. To raise a new review request, right-  
      click a file or folder and select Review Board > Create Review Request from the menu. For both 
      UCM and Base ClearCase, you can select multiple files and folders and create the review           
      request.   
 

 

Figure 13: Create Review Request (File) 
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     Select Resources page 

     This page opens when a new request is raised for a file or folder. Use it to add files and folders 
     to the review request and their respective versions for comparison.          

Figure 14: Select Review Board Server 

Figure 15: Select Resources Page 
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      You can manually enter the values for Element Path, Base Version Selector, and Current 
      Version Selector. After you click Add/Modify, the element is included in the review request 
      and is entered in the Element table.    
      
          Element Path 

          The full path of the file or folder to be added. 

 

          Base Version Selector 

          The base version of an element to use in a comparison. 

 

          Current Version Selector 

          The current version of an element or the version for which you want to create a review. 

 

          Browse 

          You can browse and select multiple files or folders from the ClearCase Resource Browser 
          dialog box within the current view context. That way, the user can select interactively and 
          avoid having to remember the versions of elements. 

                                                        
 

Figure 16: ClearCase Resource Browser 
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          Select files or folders and click OK.  

                                                  

          Add/Modify 

          Use Add/Modify to add or modify the element details in the table. After you select an 
          element from the table, the respective element details populate text fields. Modify the  
          base or current version fields and click Add/Modify to update the element in the table.          
 
      
      

      

 

 

 

 

 

Figure 17: Select Resources 
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          Element table 

          The Element table contains the details of the elements to be included in the review request. 

                                                    

       

     Remove Selected 

      Use the Remove Selected button to remove the selected row from the Element table. You can 
      select multiple elements from the table to be removed simultaneously. 
 

 

 

 

 

 

 

 

 

 

Figure 18: Element Table 
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     Detect Local Changes page 

      This page contains the list of elements and their change type. 

    

Click Next to navigate to the Publish Review Request page, where you can provide or update 
the review request details. Refer to Figure 8 to see the Publish Review Request page. 
   
After you provide the review request details, click Finish to submit the review request. 
 

      Update Review Request 

      A review request can be updated for files and folders. To update a review request, right-click 
      the file or folder and select Review Board > Update Review Request from the menu. You can  
      select multiple files or folders and update the request.  
     
      Note: In addition to new files and directories, include all previously submitted files and 
      directories to generate full and proper diffs.               

Figure 19: Detect Local Changes 
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     Note: In the Update Review Request flow, excluding the Detect Local Changes page, all 
     windows are identical to those in the Create Review Request flow. 

 

Figure 20: Update Review Request (Files/Folders) 

Figure 21: Select Review Board Server 
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          Select Resource page                   

     Click Next to navigate to the Detect Local Changes page. Refer to Figure 10 and Figure 11 to 
     see the Detect Local Changes page with the respective Update Request flow.   
  
     After the review Request ID is validated in the Detect Local Changes page, click Next to 
     navigate to the Publish Review Request page, where you can provide or update the review 
     request details. You can skip this step if you do not want to modify details, and instead  
     click Finish to update or submit the review request. Refer to Figure 88 to see the Publish  
     Review Request page.    
   
Review submitted review requests 

To view submitted review requests: 

1. Open the Task List view by clicking Window > Show View > Other > Mylyn > Task List. 
 

2. Right-click in the view and select New > Query. 

 

 

 

 

Figure 22: Select Resource 
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3. Select the Review Board repository you are already logged in to. 

 
 
 

 

Figure 23: Task List View 

Figure 24: Select Repository 



  

21 
 

4. Select values for the Query title and filters such as All, With group, From the user, To the 
user, With status, and Maximum results (requests). 

       

5. Click Finish to see the result. 
 

                                        

 

Figure 25: Edit Query 

Figure 26: Review Board Request List 
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6. Double-click the review request to open and review it. 

 

               

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 27: Review Request View 
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7. Click the Open with Web Browser icon to open the review request in a web browser or load 
the following URL directly in the browser. 

  
      https://reviewboardserver/r/170/diff/ 
          

       
8. Reviewers can view changes and provide comments. If there are no comments, then the 
      reviewer can provide approval by clicking Ship It!.   
 
9. The submitter or developer can close the review by clicking Close. 

 

Figure 28: Diff Viewer 

https://reviewboardserver/r/170/diff/

